416.467.9100 | Dundas Data Visualization | Login
Welcome Guest
Dashboard v5.0

This site makes extensive use of JavaScript.

Please enable JavaScript in your web browser and reload the page before proceeding.

Project Manager

Hide navigation
RSS
Modified on Fri, 29 May 2015 10:53 AM Categorized as Administration, Utilities
Click to return to: Documentation | Installing and Administering Dundas Dashboard | Utilities

The Dundas Dashboard Project Manager.

The Dundas Dashboard Project Manager.


Overview

The Dundas Dashboard Project Manager is a utility program that is included with the Dundas Dashboard installation. Use the Project Manager on the Dundas Dashboard server to:

  • Export application elements, such as project items and shared resources, from a selected Dundas Dashboard instance to an export file.
  • Import selected application elements from an export file to a Dundas Dashboard instance.
  • Upgrade a Dundas Dashboard export file to the current version.

Tip: For details on what the project export file contains, see this article: What does the project export contain?

The Project Manager is ideal for:

  • Migrating dashboard projects and other elements from a development instance of Dundas Dashboard to a production instance/server.
  • Letting remote sites collaborate on dashboard projects. (See the notes on multi-site collaboration for important details.)
  • Importing style resources that are published by Dundas or others.

Tip: The Project Manager supports command-line usage, which makes it possible to automate the import, export, or upgrade mode of operation.

Starting the Project Manager

The Project Manager is a standalone Windows application that is installed to the following folder by default:

Program Files\Dundas Data Visualization Inc\Dundas Dashboard\Instance1\Tools\ProjectManager

The actual path on your system will vary depending on the exact version and location of your Dundas Dashboard installation.

The folder containing the Project Manager application.

The folder containing the Project Manager application.


To start the Project Manager from Windows Explorer:

  1. Navigate to the Windows folder where the Project Manager application is installed.
  2. Double-click on the Dundas.Dashboard.ProjectManagerUI.exe file to launch the application.

To start the Project Manager from your Programs menu:

  1. Access your Programs menu.
  2. Point to Dundas Data Visualization, Inc, point to Dundas Dashboard 5.0.0 (Instance1), point to Tools, then select Project Manager.

The Project Manager can also be used from the command-line.

Tip: The Project Manager application supports keyboard navigation. For example, use the TAB key to move the current keyboard focus to the next button or control. Press ALT plus an underscored letter key to access a control.

About box

You can launch the About box for the Project Manager from the Help menu. This dialog displays the associated version number for the Project Manager application, and a data store version which corresponds to the schema of the Dundas Dashboard application databases. The data store version determines whether the Project Manager can import or upgrade an existing Dundas Dashboard export file.

The About box for the Project Manager.

The About box for the Project Manager.


Choosing the application instance

You always use the Project Manager in the context of a specific instance of Dundas Dashboard that is installed on the local machine. You are either exporting application elements from this application instance (to an export file), or you are importing application elements (from an export file) into this application instance.

Upon startup, the Project Manager automatically discovers instances of the Dundas Dashboard application that are installed on the local machine. For each instance found, an entry is added to the Application dropdown list in the Project Manager's main screen. Simply use the dropdown list to choose the application instance you want.

Choosing the application instance.

Choosing the application instance.


There may be situations where your desired application instance does not appear in the Application dropdown list (which may happen in the case of manual installations of Dundas Dashboard). In this case, you can choose your instance by opening its Dundas Dashboard Configuration File from the File menu:

Opening the configuration file.

Opening the configuration file.


In either case, the path to the configuration file is displayed as the Active profile at the bottom of the main screen. To see the full path, you may need to hover over the text with your mouse to see its tooltip.

Tooltip showing the active profile (configuration file path).

Tooltip showing the active profile (configuration file path).


The default path to the configuration file is:

C:\Program Files\Dundas Data Visualization Inc\Dundas Dashboard\Instance1\www\Dundas.Dashboard.config

Exporting application elements

Click Export Application Elements from the main screen of the Project Manager to begin exporting project items and other elements (to an export file). The Export screen is displayed.

Tip: Watch the how-to video: Project Migrate - Export

Elements of the Export screen

The Export screen lets you navigate the set of available project items and application elements, choose the items that you want to export, and initiate the export procedure when ready.

The Export screen.

The Export screen.


The main elements of the Export screen are described as follows:

  1. The Projects pane (in the top-left) lists the Dundas Dashboard projects that are available to be exported.
    • Select a project in the list in order to see the project's properties displayed in the Properties pane.
    • Click the checkbox beside a project in the list in order to choose all of its items for export.
  2. The Project pane (in the center) shows the hierarchy of project items corresponding to the selected project in the Projects pane.
    • Select a project item (such as a KPI) in order to see its properties displayed in the Properties pane.
    • Click the checkbox beside a project item in order to choose it (and its child items, if any) for export.
  3. The Properties pane (on the right) shows the properties of the selected item from the Projects, Project, or Global Items pane. Some properties, such as the object identifier (Id) and Name are read-only, while other properties are export-related options which you can set (e.g. option to export annotations for a selected project in the Projects pane). See Changing Properties for the complete list of export-related properties.
  4. The Global Items pane (in the bottom-left) lists global or application-wide elements that are available for export, such as user accounts, security groups, shared resources, bookmarks, unit definitions, and custom tokens.
    • Select a global item in order to see its properties displayed in the Properties pane.
    • Click the checkbox beside a global item in order to choose it (and its child items, if any) for export.

Choosing global items for export.

Choosing global items for export.


Selecting related items

Click the option, Automatically select related items, if you want the Project Manager to automatically select related (e.g. dependent) items when you choose an item for export. For example, if you choose a dashboard for export, the Project Manager can automatically select the data connectors, virtual tables, and KPIs it depends on for export as well.

Automatically select related items.

Automatically select related items.


Saving and loading the export configuration

Once you've selected all of the global and project items that you want to export, you have the option of saving your selections in an export configuration XML file. This allows you to:

  • Load the export configuration file the next time so you don't have to manually select all of the same items for export again. For example, this might be useful if you are exporting the same projects frequently.
  • Perform the export operation via the command-line (in which case the export configuration file is mandatory).

Load or save an export configuration file.

Load or save an export configuration file.


Changing properties

The Properties pane lets you view and optionally modify certain properties of the selected item from the Projects, Project, or Global Items pane. Some of these properties specify what data should be included in the export file. The complete set of available properties is described below.

Project properties

PropertyDescription
Export related annotation groupsIndicates whether to export the annotation groups associated with the project. Default value is True.
Export related annotationsIndicates whether to export the annotations associated with project items (i.e. KPIs and Datasets). Default value is False.

Data connector properties

PropertyDescription 
Export data from Sync database Indicates whether to export the related data that is stored in the Dundas Dashboard Sync database. This includes data imported from flat files, and the data from cached virtual tables that are based upon this data connector. In the latter case, this property only applies if the virtual table(s) are also selected for export. Default value is False.

Note: If you want to export data from the sync database but this data consists of a very large number of records (e.g. millions of records), the export operation may fail with an out of memory exception. In this case, the workaround is to use the Project Manager to export only the project-related items, and then use the Import/Export Data tool within SQL Server to copy the data in the sync database.

Begin exporting

Once you have selected the desired application elements for export, and configured their export options via the Properties pane, start the export procedure as follows:

  1. Click the Export button in the bottom-right corner of the Export screen. The Save Exported Data dialog is displayed.
    Save Exported Data dialog.
  2. A timestamped name for the export file is automatically chosen (e.g. 20130426_1805_103.ddexport). The last part of the name is the datastore version number (e.g. 103). You can keep the generated name or change it as desired.
  3. Click Save to begin exporting.

The Project Manager will check that there are actual items to be exported, and that selected projects have not been deleted in the interim, to avoid creating an empty export file.

When the export completes, a report log is displayed. You can view the report within the report dialog, or click the hyperlink at the top of the dialog to view the report as a text file.

The export report log.

The export report log.


To close the Export screen, click Close (in the bottom-right corner).

Importing application elements

Click Import Application Elements from the main screen of the Project Manager to begin importing project items and other elements from an existing export file (to the active Dundas Dashboard instance). A Backup target data store dialog appears, recommending that you back up the databases of the active Dundas Dashboard instance before proceeding further.

Tip: Watch the how-to video: Project Migrate - Import

Backup your data store

Backup your databases before importing.

Backup your databases before importing.


To backup the application databases of the active Dundas Dashboard instance:

  1. Select the Backup target databases option.
  2. A location and timestamped name are chosen for each of the database backup files to be created. You can change the path to a backup file directly in the textbox, or click the corresponding Browse button to choose a different folder location and/or filename.
  3. Click Continue. The Project Manager creates the specified SQL Server backup files (which are specific to the SQL Server version you are using).

If you don't want to create backups of the databases:

  1. Select the Don't backup option.
  2. Click Continue.

Choose the export file

Next, the Project Manager displays an Open dialog, which lets you choose the export file containing the elements to be imported.

Choose the export file that will be imported.

Choose the export file that will be imported.


Choose the export file, then click Open to open the file. If the export file doesn't need to be upgraded first, you will see the Import screen.

Upgrade the export file if needed

If the export file needs to be upgraded first, you will be asked to confirm the upgrade.

Export file needs to be upgraded first because it is an older version.

Export file needs to be upgraded first because it is an older version.


Click Yes if you want to proceed with the upgrade. The Save as new export file dialog is displayed. Click Save to begin upgrading the export file into a new file. When the operation is complete, the Upgrade Export File Report dialog is displayed. Click Close.

The Project Manager now asks you to confirm that you want to continue with importing the newly created export file.

Continue with the import after upgrading the export file.

Continue with the import after upgrading the export file.


Click Yes to continue with the import and open the upgraded file in the Import screen.

Elements of the Import screen

The Import screen lets you navigate the set of project items and application elements contained in the export file, choose the items that you want to import, and initiate the import procedure when ready.

The Import screen.

The Import screen.


The main elements of the Import screen are described as follows:

  1. The Projects pane (in the top-left) lists the Dundas Dashboard projects that are available to be imported.
    • Select a project in the list in order to see the project's properties displayed in the Properties pane.
    • Click the checkbox beside a project in the list in order to choose all of its items for import.
  2. The Project pane (in the center) shows the hierarchy of project items corresponding to the selected project in the Projects pane.
    • Select a project item (such as a KPI) in order to see its properties displayed in the Properties pane.
    • Click the checkbox beside a project item in order to choose it (and its child items, if any) for import.
  3. The Properties pane (on the right) shows the properties of the selected item from the Projects, Project, or Global Items pane. Some properties, such as the object identifier (Id) and Name are read-only, while other properties are import-related options which you can set (e.g. option to import annotations from a selected project in the Projects pane).
  4. The Global Items pane (in the bottom-left) lists global or application-wide elements that are available for import, such as user accounts, security groups, shared resources, bookmarks, unit definitions, and custom tokens.
    • Select a global item in order to see its properties displayed in the Properties pane.
    • Click the checkbox beside a global item in order to choose it (and its child items, if any) for import.

Selecting related items

Click the option, Automatically select related items, if you want the Project Manager to automatically select related (e.g. dependent) items when you choose an item for import. For example, if you choose a dashboard for import, the Project Manager can automatically select the data connectors, virtual tables, and KPIs it depends on for import as well.

Automatically select related items.

Automatically select related items.


Changing properties

For certain types of project items, such as data connectors, you can review their properties via the Properties pane and change them if necessary. For example, a data connector from an export file may be pointing at remote business databases which you will not have access to from the active Dundas Dashboard instance. In this case, you need to change the connection string accordingly before starting to import.

Change the connection string for a data connector.

Change the connection string for a data connector.


You can change the connection string by typing the new value manually in the Properties pane. Alternatively, for certain data connector types, you can click the ellipsis button to access a specific screen for modifying the connection string.

Changing connection properties for a SQL Server data connector.

Changing connection properties for a SQL Server
data connector.


You can also change the Connect As properties for your data connector (e.g. if the connection is for SSAS - SQL Server Analysis Services):

Connect As settings.

Connect As settings.


The complete set of import-related properties is described next.

Project properties

PropertyDescription
Import related annotation groupsIndicates whether to import the annotation groups associated with the project. Default value is True.
Import related annotationsIndicates whether to import the annotations associated with project items (i.e. KPIs and Datasets). Default value is False.

Data connector properties

PropertyDescription 
Import data from Sync database Indicates whether to import flat file data, and the data from cached virtual tables that are based upon this data connector. In the latter case, this property only applies if the virtual table(s) are also selected for import. Default value is False.
Connect asLets you modify the Connect as settings for any type of data connector.
Connection stringLets you modify the connection string for data connectors based on relational data providers.
Data SourcesLets you modify the data source connection string for flat file data connectors.

Resolving name conflicts

When an element to be imported has the same name and location as an existing object from the active Dundas Dashboard instance (but with a different object identifier), the Project Manager offers a default renaming for the element. For example, if the active instance has a dashboard named Sales, and you import another similarly named dashboard (with a different object identifier), the Import screen will show the imported dashboard as Sales (2). Such modified names are marked with a red color and are editable, which lets you choose different custom names as desired.

Begin importing

Once you have selected the desired application elements for import, and configured their import options via the Properties pane, click Import to begin the import procedure.

When the import completes, a report log is displayed. You can view the report within the report dialog, or click the hyperlink at the top of the dialog to view the report as a text file.

The import report log.

The import report log.


To close the Import screen, click Close (in the bottom-right corner).

Note: When you start the import procedure, it first determines if the target Dundas Dashboard instance has a checked-out instance of an object (such as a dashboard) that is to be imported. In this case, the Project Manager displays a confirmation dialog asking if you want to proceed or not, since continuing will result in the checked-out object being discarded and replaced. Additionally, if another user has this object open for editing at the same time, the user will not be permitted to save the object anymore once the import is complete.

Recycle your IIS Application Pool

After completing an import, it is recommended to recycle your IIS Application Pool:

  • Start the IIS Manager.
  • Expand the local computer folder.
  • Expand the Application Pools folder.
  • Select the application pool you want, access its context menu, and choose the Recycle option.

Upgrading an export file

Follow these steps to upgrade an old export file to the current version (as determined by the data store version of the Project Manager).

  1. Open the File menu from the main screen of the Project Manager.
  2. Click Upgrade Old Export File.
    Upgrade old export file option.
  3. A Backup target databases dialog appears, recommending that you back up the Sync database of the active Dundas Dashboard instance before proceeding further. See Backup your data store for details.
  4. Use the Open the old export file dialog to choose the export file that you want to upgrade.
  5. The Save as new export file dialog asks you to choose where you want to save the upgraded file. Click Save to begin the upgrade.

The Upgrade Export File Report dialog is displayed when the upgrade operation is complete.

Upgrade notes

Some notes and limitations to be aware of regarding upgrade of old export files:

  • Only export files created with Dundas Dashboard version 2.5 or higher can be upgraded.
  • If the export file contains partial data (e.g. it contains a dashboard but not any of the KPIs, virtual tables, or data connectors that it depends on), it cannot be upgraded.

Command-line usage

The Project Manager offers a command-line mode of operation for both import and export. There is also a mode for upgrading an export file to the current version.

To see the command-line syntax, open a command-line window, navigate to the Windows folder where the Project Manager application is installed, then type:

Dundas.Dashboard.ProjectManager.exe /?

Import

The Project Manager can be used via the command-line to perform an import operation (without the appearance of the user interface). When importing via the command-line, all items from the export file are imported, including annotations and annotation groups. Cached and imported data (e.g. from flat files) is also always included in the import (if this data was exported into the export file).

The syntax for the command-line usage is as follows:

Dundas.Dashboard.ProjectManager.exe /import /config=DDConfigFile /data=exportFile /backup=backupOption

Where:

DDConfigFile is the full pathname of the Dundas Dashboard Configuration File for the Dundas Dashboard instance you want to import to.

exportFile is the full pathname of the export file (.ddexport) containing items to be imported.

backupOption can be one of:

A — Create backup files for the data store and sync databases; halt if backup creation fails.
B — Create backup files for the data store and sync databases; continue if backup creation fails.
C — Don't create backup files.

Below is an example usage:

Dundas.Dashboard.ProjectManager.exe /import /config="C:\Program Files\Dundas Data Visualization Inc\Dundas Dashboard\Instance1\www\Dundas.Dashboard.config" /data="C:\TEMP\20120720_1423_35.ddexport" /backup=C

You can view a report log when the import procedure is complete (e.g. C:\Program Files\Dundas Data Visualization Inc\Dundas Dashboard\Instance1\Tools\ProjectManager\20120720_113601_ImportTask.txt).

Note: After completing an import, it is recommended to recycle your IIS Application Pool.

Export

The Project Manager can also be used via the command-line to perform an export operation (without the appearance of the user interface). This option is useful for batch operations and repetitive or scheduled tasks.

In order to export via the command-line, it is necessary to create an export configuration XML file which specifies the items to be exported.

The syntax for the command-line usage is as follows:

Dundas.Dashboard.ProjectManager.exe /export /config=DDConfigFile /data=targetExportFile /exportConfig=exportConfigFile

Where:

DDConfigFile is the full pathname of the Dundas Dashboard Configuration File for the Dundas Dashboard instance you want to export from.

targetExportFile is the full pathname of the export file (.ddexport) to be created.

exportConfigFile is the full pathname of the export configuration file (.xml) that specifies the items to be exported.

Some additional notes:

  • An export configuration file can be edited manually in any text or XML editor (however, this is not recommended).
  • Although the Data store version is stored in an export configuration file, the Project Manager will allow the use of older-versioned export configuration files.
  • Only items explicitly defined in the export configuration file are exported. Any new project items that were created will not be exported. If you want to include newer items for export, you must load the existing export configuration using the Export screen, manually select the new items for export, then save the export configuration.
  • If an item is defined in an export configuration file but is not actually present in the Dundas Dashboard instance (e.g. it may have been deleted after the export configuration was saved), it will be ignored during the export operation.

Upgrade an export file

The Project Manager can be used via the command-line to perform an upgrade of an export file to the current version (without the appearance of the user interface).

The syntax for the command-line usage is as follows:

Dundas.Dashboard.ProjectManager.exe /upgradeExportFile /config=DDConfigFile /sourceData=sourceExportFile /targetData=targetExportFile /backup=backupOption

Where:

DDConfigFile is the full pathname of the Dundas Dashboard Configuration File for the target Dundas Dashboard instance.

sourceExportFile is the full pathname of the source (old) export file (.ddexport).

targetExportFile is the full pathname of the target (new) export file (.ddexport) to be created.

backupOption can be one of:

A — Tries to create backup file for sync database, stops execution if backup failed.
B — Tries to create backup file for sync database, continues execution if backup failed.
C — Don't create backup files.

Usage scenarios

Automating the transfer of project items from dev to production

Below are some example steps for automating the transfer (export and subsequent import) of project items from a development/test/staging instance of Dundas Dashboard to a production instance:

  1. On the development/test/staging instance:
    • Use the Project Manager of the development instance to select items for export and save to an export configuration file.
    • Create a batch file that uses the command-line syntax to perform an export operation and place the resulting ddexport file in a shared network folder.
    • Define a scheduled task in Windows to run the batch file periodically as desired.
  2. On the production instance:
    • Create a batch file that uses the command-line syntax to import the ddexport file which is located in a network folder.
    • Define a scheduled task in Windows to run the batch file periodically as desired.

Multi-site collaboration

The Project Manager lets you export a dashboard project as a ddexport file, which can then be sent to remote sites and imported. This lets your remote sites work on an exact copy of the original project where even the identifiers (GUIDs) are all the same. However, as with any endeavor where you have multiple people or teams working on the same thing, there are some potential trouble spots to be aware of.

For example, if each of the remote sites intend to further develop dashboards independently based on the copied project, then all is good and there are no issues. However, if one or more remote sites do further dashboard development on the copied project, and want to eventually merge (via the Project Manager's import function) the work back into the original project/site, then there are some important points to remember or else this merging will fail:

  • The remote sites should not re-discover the data connectors in the project as this will cause identifiers to change, which will make merging impossible later.
  • The data connectors in the project should reference data sources that are accessible to every one of the remote sites. For example, the copied project at each remote site could reference the same database server instance. If this is not possible, and each remote site must use a separate data source, then the separate data sources should at least be kept in sync.

Notes

SQL Server Express

The Project Manager may fail to export or import a large dashboard project due to CPU and memory limitations of SQL Server Express (e.g. 1 CPU and 1 GB of RAM). A workaround is to export or import a portion of the project at a time (e.g. a few dashboards).

SQL Server permissions required for import

In order to import to a Dundas Dashboard instance, the user running the Project Manager application requires the following SQL Server role memberships on the Dundas Dashboard DataStore and Sync databases:

  • db_owner
  • public

If the user is the person who installed the Dundas Dashboard instance, these roles should already be granted. Otherwise, your database administrator must grant these roles to the (Windows) users who need to import using the Project Manager.

Related topics


Click to return to: Documentation | Installing and Administering Dundas Dashboard | Utilities

About Dundas | Contact Us Follow us on Twitter! | Privacy Statement | Report Site Issues

Copyright © 2009-2014 Dundas Data Visualization, Inc.