<![CDATA[Dundas Support Zone - The ‘Microsoft.ACE.OLEDB.12.0’ provider is not registered on the local machine]]>http://support.dundas.com/Dashboard5.Error_Message_Microsoft_ACE_OLEDB_12_0.ashxWed, 17 Jun 2020 20:06:40 GMTScrewTurn Wiki RSS Feed Generator<![CDATA[The ‘Microsoft.ACE.OLEDB.12.0’ provider is not registered on the local machine]]>http://support.dundas.com/Dashboard5.Error_Message_Microsoft_ACE_OLEDB_12_0.ashx TroubleshootingPrevious


Error Message

The ‘Microsoft.ACE.OLEDB.12.0’ provider is not registered on the local machine.

Error when creating a data connector for Access or Excel database.

Error when creating a data connector for Access or Excel database.


Symptoms

When you create a Data Connector for Access or Excel, you may receive the following error message: The ‘Microsoft.ACE.OLEDB.12.0’ provider is not registered on the local machine.

Causes

  1. You may not have installed yet the Microsoft Access Database Driver.
  2. You have installed the wrong version of the driver. For example, you've installed the 32-bit instead of the 64-bit version.

Resolution

Install the correct driver on the server. You have three possible options:

  1. If you installed the 64-bit version of Dundas Dashboard, you need to install the 64-bit driver: Microsoft Access Database Engine 2010 Redistributable
  2. If your machine is running Windows 64-bit and you have Office 32-bit installed, you can force the 64-bit Access driver to install by running the installer with the following command: AccessDatabaseEngine_x64.exe /passive
  3. If, for some reason, you need to install the 32-bit Access driver, you can run your IIS or application pool in 32-bit mode, so that the 32-bit drivers will function correctly with Dundas Dashboard. In this case, you will also need to configure the Dundas Dashboard Scheduler to run in 32-bit mode, or else scheduled imports will not work.



Related topics

]]>
Julius M. (juliusm@dundas.com)Mon, 16 Jun 2014 11:23:59 GMT8F791B6916444CB61FFB70BB2DE6D666